Unity to iOS "unsupported graphics API of type -4"

0 votes
asked Jan 10, 2018 by anti51 (220 points)

I have a unity project that used to work. Now i'm getting the error "EasyAR is running with an unsupported graphics API of type -4" in XCode debugger with Iphone 6s on iOS 11.2 and the screen stays black.

The HelloARVideo example, which was the base for my project, is working. I compared all the settings i can think of and they are exactly the same.

Of course i took all the steps shown in the doc.

I also deleted all the files but assets-folder and reimported into a new project. Didn't work.

1 Answer

0 votes
answered Jan 11, 2018 by anti51 (220 points)
I worked around the problem by exporting my scene and importing it into the working HelloARVideo Example, then switching to target platform iOS. Now it works.

But after switching again to target platform Android, the AR targets are being recognized, but the linked videos are either not playing or invisible.

After again using a "blank" HelloARVideo Example with my assets imported now i'm getting a invalid key on Android. I'm pretty sure that all the settings are correct.
Welcome to EasyAR SDK Q&A, where you can ask questions and receive answers from other members of the community.