Is there a problem whith iOS build ?

0 votes
asked May 7, 2021 by eventorizon (160 points)
edited May 7, 2021 by eventorizon


I've just create a new pro license key for iOS .. .an additionnal key because, an android was existing yet .. and all it's  ok for the android's build, even on Google Play.

But for iOS ... not !

Of course I've put the new gererated key in the ios build, push all via xcode to apple store, put it in test Flight application.... i've check 2/3 times the bundle names in Unity/Xcode/Apple Store .. they are good !

Each time i open the ios application i've got an "unvalid key" error .... what's happen ?? ... i'm so frustrated , my client is waiting for me.

Note that i've also test the build in amy local ipad, and it's still the same error ! 

Does someone has encoutered the same issue ?

Do i need to wait 24/48h untill this new key is actvated by easAR'services ?

****EDIT : it's seems to be ok for the "key error"on a local iPad ... but now imageTarget are recognized => Ok

But the augmentation move when i move the camera  ! How can i fix that ? I precise that it's working well with the same code on the android version.

Perhabs because i need not to embed the arkit framework in xcode to be able to test on local ipad ?

2 Answers

0 votes
answered May 7, 2021 by kenn (18,750 points)
From your description, it seems that invalid key error has disappeared. Technically, you are changing bundle id of the license key which will generate a new one in the key history. The new key will be effective immediately.

But I am a little confused with the remaining questions in your post. More detailed description about expected and real behavior or some error logs would be helpful.

PS. Would you mind sharing how the invalid key error disappear by the way? We could not reproduce the issue.
commented May 8, 2021 by eventorizon (160 points)
Thanks for your comment.
For the "invalid key" part, it's now ok .. it was just my fault . With 2  XCode windows opened, i was building the wrong one with the wrong key !
I confirm that the generated key is immediatly valid. Cool.

But now i can test on a real device (ipad), and i've got 2 new problems :
1) upsidedown camera view  (up is down)
2) when image are founded, the tracking is really bad ... the augmentation don't stay on the image marker, but move when i move the device.

I'm working with easyar 4, unity 2020.1.14f1, XCode 12.4. Testing on Ipad Apple A12.

I've tried to add some code to shaders like it's said in these posts (, but i've got still the same behavior.

The behavior is the same in the Unity editor ... the tracking is not stable, but the camera is not upside downed.

Does someone has encoutered the same issue with iOS ?
I've got the exactly same code for android ... and it's working really good. Application is already on the Google Play store.
0 votes
answered May 8, 2021 by eventorizon (160 points)

everything is now OK for my ipad ... i was using 4..2 easyAR version in Unity 2020.1

I've switched to easyAR 4.3 with the samples included ... it's all working good with really good tracking for image tagret on iOS ! The new easyAR plugin's integration with Unity Package Manager is really cool and we can now add samples with ease ... GREAT !

So use EasyAR 4.3 with Unity 2020.3 based on samples scenes is OK for me
Welcome to EasyAR SDK Q&A, where you can ask questions and receive answers from other members of the community.