Black Screen Preview

+1 vote
asked Feb 8, 2018 by monteysalbert09 (130 points)
When I press the 'Play' button in Unity EasyAR does not show the camera, if I pack the project it works fine, but from Editor there is only a black screen. This begin to happen since yesterday.


2 Answers

0 votes
answered Feb 10, 2018 by jaloisus (140 points)
I tried out their samples for Android + Unity, having the same black screen.
commented Feb 16, 2018 by monteysalbert09 (130 points)
No matter how much I have read about it, there is no answer.
+2 votes
answered Feb 22, 2018 by suchonm (180 points)
im having a similar problem. Mine work fine when i hit play but black screen when i built it on android
commented Mar 3, 2018 by bellscotcv (110 points)
Having the same problem as well
commented Mar 9, 2018 by yofercho (100 points)
I am having the same problem ... did you solved it?
commented Apr 25, 2018 by drmjr9 (100 points)
I have the same issue when trying to build any of the Unity samples ( for Android (Internal build system).

The camera view is just black so I cannot assess any of the samples. I also noticed that the samples don't ask for device permissions at all when installing the APK on my Android phone.

But I can run the samples just fine in Windows if I just press Play.
commented May 23, 2018 by frencich (130 points)
someone has solved?
commented Oct 12, 2018 by magnetica (290 points)
it's a known issue. try using unity 2018.1
a lot of People are waiting the updated version.
Welcome to EasyAR SDK Q&A, where you can ask questions and receive answers from other members of the community.