Problem with solving black screen issue on IOS Device by replacing AppController

0 votes
asked Dec 4 by artius (150 points)
Hi. I'm trying to build my Unity Project with EasyAR SDK for IOS. At first i had got black screen, but all targets was recognized. Then i had tryed the solution from FAQ with replacing AppController with EasyARAppController.mm but Xcode returns me an error:

Undefined symbols for architecture arm64:
  "_MMTUnityRenderEvent", referenced from:
      _ezarUnityRenderEventMerge in EasyARAppController.o
  "_MMTUnitySetGraphicsDevice", referenced from:
      _ezarUnitySetGraphicsDeviceMerge in EasyARAppController.o
ld: symbol(s) not found for architecture arm64
clang: error: linker command failed with exit code 1 (use -v to see invocation)

I also had included GameKit and some other frameworks in Unity EasyARAppController settings, but it didn't help.
Maybe you can help me to solve this issue, or direct me where to dig?
Great thanks.

1 Answer

0 votes
answered Dec 6 by zhnagjian (1,200 points)
Hello,

This problem may be due to the normal compilation bar. Gamekit.Framework should be introduced into the Build Phases before normal compilation.

I Hope my solution can give you some help.
commented Dec 11 by artius (150 points)
Hello, thanks for your reply.
I have added Gamekit.framework to Linked Frameworks and Libraries and to Link binary with libraries in Build Phases, also i have tried different solutions for this issue frome google, but it still gives me the same error. Please give me advice what i have to do with this issue? Maybe I miss something?

Undefined symbols for architecture arm64:
  "_UnityGetMetalDrawableCommandQueue", referenced from:
      MetalContext::PrepareCommandBufferIfNeeded() in libiPhone-lib.a(MetalContext.o)
  "_UnityGetMetalCommandQueue", referenced from:
      MetalContext::PrepareCommandBufferIfNeeded() in libiPhone-lib.a(MetalContext.o)
  "_UnityGetGLViewController", referenced from:
      -[AchievementWrapper showAchievementsUI] in libiPhone-lib.a(GameCenter.o)
      -[LeaderboardWrapper showLeaderboardUI:withTimeScope:] in libiPhone-lib.a(GameCenter.o)
  "_UnityGetMetalBundle", referenced from:
      MetalBundleImpl() in libiPhone-lib.a(PluginInterfaceGraphicsMetal.o)
  "__ios91orNewer", referenced from:
      ____Z22IsStylusTouchSupportedv_block_invoke in libiPhone-lib.a(iPhoneInputImpl.o)
  "__ios90orNewer", referenced from:
      iphone::OnProcessTouchEvents(NSSet*, NSSet*) in libiPhone-lib.a(iPhoneInputImpl.o)
      ____Z21IsForceTouchSupportedv_block_invoke in libiPhone-lib.a(iPhoneInputImpl.o)
      iphone::NewInput::ProcessTouches(NSSet*, NSSet*) in libiPhone-lib.a(NewInputTouch.o)
      ____ZN6iphoneL21IsForceTouchSupportedEv_block_invoke in libiPhone-lib.a(NewInputTouch.o)
  "_MMTUnitySetGraphicsDevice", referenced from:
      _ezarUnitySetGraphicsDeviceMerge in EasyARAppController.o
asked Dec 11 by artius (150 points)
edited Dec 11 by artius
Solve black screen issue IOS without Mobile Movie Texture
Welcome to EasyAR SDK Q&A, where you can ask questions and receive answers from other members of the community.
...