App was working but now Invalid Key error

+1 vote
asked Oct 26, 2017 by googleybear (160 points)
Hi,

I had everything set up and building to my phone and working fine.

Now suddenly it is giving me the 'Invalid Key or Package Name' error. I haven't touched any of the project settings and the key is correctly entered.

The only thing I changed was some settings on the Video player script in my scene.

Why would this happen?

2 Answers

0 votes
answered Jun 29, 2018 by albert52 (31,830 points)
selected Jul 3, 2018 by albert52
 
Best answer

The error is obvious and the problem appears in the Key or Package Name.

1) About Key:

2) please check whether your Package Name is exactly the same as when it was created on the official website

3) please check whether your key exists

4) whether the same problem will occur if the network is turned off

commented Jun 29, 2018 by felicebuonanno (110 points)
Just in case someone is having the same issue:
1) Make sure you are using the correct key and package name
2) Make sure the target image you are loading is actually present in your assets folder - for some reason the library shows the package or key error if that is not the case
+1 vote
answered Oct 30, 2017 by albert52 (31,830 points)

Hi,

I'm sorry to reply you so late.

1.Notice that your bundle id (Unity or Android) is the same as key(website's package name)

2.Did you delete this key on the website?

commented Oct 31, 2017 by googleybear (160 points)
edited Oct 31, 2017 by googleybear
I added the bundle id after I had the error to try and fix the problem, thinking it might be needed to work.

I only need Android. As you can see I set up 2 licenses, 1 with bundle id and 1 without, and neither of them work. Do I need to enter the bundle id if I'm just using Android?

I know why it stopped working at least. The app worked when the phone wasn't connected to my wireless internet. Once it was connected it showed the 'invalid key' error.

I assume the licensing never worked but only had an error when it was able to connect to the internet and check the license.

That being said, I followed the instructions and I still cant get it to work.
commented Feb 14, 2018 by natasha1403 (100 points)
Hey! It is giving me same error, were you able to make it work after that?
commented Jun 28, 2018 by felicebuonano (100 points)
Did anyone manage to solve this issue? Out of the blue I started getting the error on Android..
commented Dec 16, 2019 by artowl (100 points)
Same issue here. Was working fine until I uploaded the package to playstore now I get the error.  Anyone have any solutions?
Welcome to EasyAR SDK Q&A, where you can ask questions and receive answers from other members of the community.
...