Error: Invalid Key

+1 vote
asked Nov 2, 2018 by ericlybbert (130 points)
edited Nov 2, 2018 by ericlybbert
I am working on a Mac and trying to get an iPhone app working. I finally got the camera to come on when previewing on a mac, which required updating to EasyAR 2.3.0 and switching the graphics to OpenGL Core. I don't get an invalid key error when opening on a mac, but once I port it to my iPhone it comes up with the Error: Invalid Key message. I tried creating a new SDK Authorization using the 2.0 license key, and I tried using a previous SDK Authorization with the 2.0 license key. I am sure that I have Bundle ID and License Key in the correct places in Unity. What else could be going on?

Update

Alright, I ran through things again with a new project. I was able to get it to recognize the key, but it still doesn't bring up the camera. All I am seeing is the horizon when I open the app on my iPhone. It does however open the camera and recognize my target just on my Mac.

Here is a video of me creating this last project, which I hope is helpful in troubleshooting: http://youtu.be/PRNC3R_17wo

1 Answer

0 votes
answered Nov 6, 2018 by albert52 (31,890 points)

The error is obvious and the problem appears in the Key or Package Name.
1) About Key:

2) please check whether your Package Name is exactly the same as when it was created on the official website
3) please check whether your key exists
4)Make sure the target image you are loading is actually present in your assets folder - for some reason the library shows the package or key error if that is not the case

commented Nov 18, 2018 by lsummers (130 points)
No, I've been seeing this problem on and off all day.

#1 - the keys MATCH exactly.

#2 - looking at wireshark, the activation server is generating a Gateway Error 502.  

This is a problem with their activation server going offline and breaking, and causing the applications to INCORRECTLY say that the license is invalid, when it is in fact, perfectly valid.
commented Nov 20, 2018 by kenn (4,540 points)
edited Nov 20, 2018 by kenn
Not every invalid key is caused by gateway error. And most of the time, it is really caused by unmatch key/package name. We are trying to make the validation process better in the coming EasyAR SDK 3.0.
It is the first time we receive failed validation from the right key (confirmed). It is possible related to some recent server changes, and we will fix that ASAP.
Welcome to EasyAR SDK Q&A, where you can ask questions and receive answers from other members of the community.
...