HelloARVideo appears as black on Android

0 votes
asked Oct 31, 2018 by jgcine (120 points)
Good day,

Exporting to Kindle Fire 7 (Android 5.1).  HelloARVideo test app runs fine, except that on discovering the targets the 3D geometry appears but with a black surface and no video.

This with Easy AR 2.3.0 and the latest 2018 unity.

When I downgraded to the the most recent 2017 unity, the same Easy AR package worked fine.

My issue is therefore currently resolved, but I wanted to make others aware of the problem and of my solution.

Thank you for a wonderful product.

3 Answers

0 votes
answered Oct 31, 2018 by albert52 (31,960 points)
Can you tell me the specific model of your mobile phone?
commented Oct 31, 2018 by jgcine (120 points)
Good day,

It is an Amazon Kindle Fire 7 (2015).  It runs Fire OS, which is an Amazon version of Android 5.1.
+1 vote
answered Nov 2, 2018 by ardevptw (160 points)
I'm having the same issue with the most recent Unity (Unity 2018.2.11f1) and a Nexus 5 on Android 6.0.1. I really hoped EasyAR 2.30 would fix that problem, which is now present for at least 5 (!) months ...

The console throws the following error message:

Assertion failed: OPENGL NATIVE PLUG-IN ERROR: GL_INVALID_FRAMEBUFFER_OPERATION: Framebuffer is not complete or incompatible with command
UnityEngine.GL:IssuePluginEvent(Int32)
EasyAR.Augmenter:RetrieveVideoBackground()
EasyAR.ARCameraBaseBehaviour:Update()

Unfortunately a downgrade to 2017 isn't reasonable for my use case. Some help would be appreciated.
commented Nov 13, 2018 by faiyaz5yaz (100 points)
try 2018.1.8f
commented Feb 6 by dhsgame (230 points)
that will resolve issue ??
commented Feb 7 by faiyaz5yaz (100 points)
yes..  i am using 2018.1.8f version of unity .
0 votes
answered Feb 6 by dhsgame (230 points)
Hey , i am getting same error , even in unity 2018.3.0 , if anybody has solution plz let me know .
commented Mar 4 by numonic (200 points)
No answer at the moment I just uploaded a Question to be answered.
Welcome to EasyAR SDK Q&A, where you can ask questions and receive answers from other members of the community.
...