Background video is not rendered on Unity 2018.2 for Android

+2 votes
asked Aug 16, 2018 by markhurry (260 points)

Unity 2018.1.7f1 android renders video background but using the latest version Unity 2018.2.3f1 for android you get a black screen. However tracking still works.

This was reported initially on 6th August by tabworld and is a problem for a number of developers. As you can see from tabworld's thread.

The problem exists for my app and all the EasyAR Unity examples

As yet there has been no response from EasyAR about a fix

2 Answers

0 votes
answered Aug 17, 2018 by albert52 (31,920 points)
This is a known problem. Thank you for your feedback. We're making plans to fix it.
commented Aug 17, 2018 by markhurry (260 points)
when will there be a fix?
0 votes
answered Oct 30, 2018 by kenn (4,160 points)
EasyAR SDK 2.3.0/2.2.1 have been released. They are compatible with Unity 2018. You can get it from EasyAR website. You may need to refresh the webpage if you didn't see them.

Additional For MacOS, because Unity 2018 use Metal by default, you may also need to change the settings to use OpenGL Core. Look at Unity title bar and make sure there is OpenGL instead of Metal.

BTW, we are working on a perfect solution in EasyAR SDK 3.0, which will use the most of Unity features instead of a custom renderer. We will make the whole EasyAR Unity Plugin open source.
Welcome to EasyAR SDK Q&A, where you can ask questions and receive answers from other members of the community.
...