Swift compatible

0 votes
asked Aug 20, 2017 by n1tesh (120 points)
I tried to convert the sample code into Swift but it didn't worked for me. Camera is not starting.

Project Repo: https://github.com/n1tesh/EasyAR-Swift-Demo

Please let me know if I am anything wrong or missing something while converting the code.

3 Answers

0 votes
answered Aug 20, 2017 by albert52 (31,890 points)

hi,

Can you tell me your  Xcode version ?

 

commented Aug 30, 2017 by n1tesh (120 points)
I'm on Xcode 8.3.3
commented Aug 30, 2017 by n1tesh (120 points)
If you have already done converting or using it via bridging then please share the sample project.
0 votes
answered Sep 7, 2017 by kenn (4,540 points)
Stay tuned. EasyAR SDK 2.1 with Swift support is on the way. We have changed API a bit so we cannot share it right now for 2.0.0. I will come back in a few days.
0 votes
answered Sep 12, 2017 by kenn (4,540 points)

EasyAR SDK 2.1 with Swift support released! Get it from https://www.easyar.com/view/download.html

Welcome to EasyAR SDK Q&A, where you can ask questions and receive answers from other members of the community.
...