AR camera stays black with Unity 2018.2 (Android, Editor)

+17 votes
asked Jul 14, 2018 by tabworld (280 points)
Hello There,

I built an existing  project created with Unity 1018.1 and tried to build it - unmodified - with Unity 2018.2 which was just released.

When running in the Editor on osx the screen stays black while the webcam indicator is switched on. There are no error or even warning messages in the console.

On Android the same happens; black screen, no obvious warnings.

How can this be fixed?

Is there anything I can do to test this further?

3 Answers

–5 votes
answered Jul 14, 2018 by albert52 (31,850 points)
PlayerSetting : OpenGLES2
commented Jul 15, 2018 by tabworld (280 points)
Yes that was the first thing I checked (and indeed had to change) but didn't work.

Some more observations:

Unity 2018.1.7f1 still works, there is some change specific for the 2018.2 upgrade.

The problem has to do with the "realityPlane" and/or the associated script / dll as this stays completely black when the camera switches on. All other info messages still show in the console (loading of trackables etc).
commented Jul 19, 2018 by davidevora (100 points)
I have the same problem once I update to unity 2018.2.0f2 from 2017 version.
Now the tracking works but theres no background camera feed showing in the screen.
Have you find a solution?
commented Jul 23, 2018 by rekkuzan (360 points)
I encounter the same issue. Work fine on 2018.1.8f and on 2018.2.0f2 the video background is not rendered (But recognition works).
commented Jul 24, 2018 by pkfapps (140 points)
I have got the same issue, I am on Unity Version 2018.2.0f2.
commented Jul 26, 2018 by albert52 (31,850 points)
The current version of EasyAR does not support Unity 2018.2
+1 vote
answered Aug 6, 2018 by nobakab (160 points)

There was this in Release Notes of Unity version 2018.2.0:

Android: WebCamTexture is implemented using android.hardware.camera2 package for devices which support API level 21

I suspect this change causing issue with EasyAR using webcam and result a black camera.

The last version before that (2018.1.9) works well.

commented Aug 7, 2018 by tabworld (280 points)
Correct; I noticed that... however, with other projects the WebCamTexture works almost flawless (apart from a minor issue on Android when shutting down).

Also this affects the Editor as well so I'm afraid this issue is caused by something else.

An official response from EasyAR would be highly appreciated!
commented Aug 16, 2018 by markhurry (270 points)
I have same problem since upgrading Unity. Some sort of official response would be good as I have to use latest version of Unity which fixes a prefab instantiation bug. At the moment I am dead in the water without a fix
commented Aug 17, 2018 by markhurry (270 points)
I submitted this question again and also sent a direct email to and got this non committal  response


This is a known problem. Thank you for your feedback. We're making plans to fix it.

commented Aug 29, 2018 by pkfapps (140 points)
is there any update on this issue?

commented Oct 23, 2018 by techhead (100 points)
Did anyone ever have any luck with this?

I am running the latest versions of Unity  (2018.2.12f1) and EasyAR and am still getting a black screen, instead of the camera view, when running it on my Android device.

I disabled/enabled the PlayerSetting : OpenGLES2 setting with no luck either.

Any help appreciated.

Thanks,  Simon
commented Oct 28, 2018 by raidel (160 points)
This error has me in trouble
Does anyone know when the next version will come out?

+1 vote
answered Oct 30, 2018 by kenn (18,750 points)
edited Oct 30, 2018 by kenn
EasyAR SDK 2.3.0/2.2.1 have been released. They are compatible with Unity 2018. You can get it from EasyAR website. You may need to refresh the webpage if you didn't see them.

Additional For MacOS, because Unity 2018 use Metal by default, you may also need to change the settings to use OpenGL Core. Look at Unity title bar and make sure there is OpenGL instead of Metal.

BTW, we are working on a perfect solution in EasyAR SDK 3.0, which will use the most of Unity features instead of a custom renderer. We will make the whole EasyAR Unity Plugin open source.
commented Oct 30, 2018 by bigbaak (720 points)
Big thanks) New version of SDK helped me.
Unity3D 2018.2.13f1
commented Apr 12, 2019 by gabzilla (100 points)
Im developing on MacOS, i'm still on Unity 2018.2.12f1, with the latest SDK 2.3.0, I'm still have the black screen, with no video display. I've already set the GPU to OpenGLCore, but still the same issue.
commented Nov 12, 2019 by deejhay2 (140 points)
pls help i am using unity 2018.1 and EasyAR 2.3 still black screen on my android can some one help me on this many thanks
commented Nov 12, 2019 by kenn (18,750 points)
Please look at the logs tagged with Unity and EasyAR using commandline logcat or Android Studio to see if anything unusual happens.
EasyAR SDK 3 has been released for a while and eliminated the dependency on OpenGL, maybe you want to try that first.
By the way, try samples first. They should work.
commented Nov 14, 2019 by deejhay2 (140 points)
UnityEditor.BuildPlayerWindow+BuildMethodException: 3 errors
  at UnityEditor.BuildPlayerWindow+DefaultBuildMethods.BuildPlayer (BuildPlayerOptions options) [0x0021f] in C:\buildslave\unity\build\Editor\Mono\BuildPlayerWindowBuildMethods.cs:182
  at UnityEditor.BuildPlayerWindow.CallBuildMethods (Boolean askForBuildLocation, BuildOptions defaultBuildOptions) [0x00065] in C:\buildslave\unity\build\Editor\Mono\BuildPlayerWindowBuildMethods.cs:89
UnityEngine.GUIUtility:ProcessEvent(Int32, IntPtr) this is now the error i am using sdk 3
commented Nov 14, 2019 by kenn (18,750 points)
That is probably not the error itself. There should be more lines.
Before continue report errors, did you try to run a Unity only project? And did you try samples? And did you use an uncommon Unity setting?
Welcome to EasyAR SDK Q&A, where you can ask questions and receive answers from other members of the community.