closed Webcam doesn't work in editor I have tried EVERYTHING!

0 votes
asked Oct 9, 2021 by speedoflint (120 points)
closed Oct 12, 2021 by kenn

Hello there,

I have tried EasyAR over a year ago, and I told to myself if I ever need an AR library I will be using this!
I have tried it thoroughly and it was okay. BUT NOW IT IS NOT :(

I tried easy AR coloring book sample for example, with my webcam 1 year ago, it was working just fine. Now, even tho the camera works, target recognition doesn't recognize the image at all.

As you can see from the screen shot HERE

What am I supposed to do? I need constant testing and I don't want to switch back to VUFORIA.

In forums you guys didn't help at all about this issue, I have checked!

And in the tutorial "Starting from zero" you guys mentioned yourselves that it is supposed to work with a webcam!

Please help, I love you guys :(

EDIT: I forgot to mention that, if I build on android, everything works correctly.

EDIT 2: I was using Unity Version 2020.3.18f1 and just to give it a try, I switched to Unity Version 2019.4.20f1 and it started working... Do you guys have any clue?

closed with the note: was closed by the author, original note was "When I imported EasyAR latest library to a brand new project, it started working as intended. I don't know what was the cause but I'll go from here "

1 Answer

0 votes
answered Oct 12, 2021 by kenn (18,750 points)
For anyone coming into this thread looking for a solution, EasyAR Sense Unity Plugin >= 4.2 has this issue fixed.

For issues found in Unity versions released after some specific EasyAR release, It is always suggest to try the latest EasyAR release first.

More details explained here:
Welcome to EasyAR SDK Q&A, where you can ask questions and receive answers from other members of the community.