Image Target Gizmo Cover Sprite Renderer

0 votes
asked Dec 28, 2020 by wjrivera (700 points)
edited Feb 13 by wjrivera

The gizmo that uses the image target is always in front of the sprites, I would like to know how to make this not happen.

in this video you can see what I mean:

Video

I understand that I must modify the shader that the image target uses but I have not managed to make it work.

1 Answer

0 votes
answered Feb 9 by kenn (11,330 points)

What do you mean by "the image target does not cover the sprite renderer"?

commented Feb 13 by wjrivera (700 points)
Thank you, I have modified the question and I have put a video with what I am trying to say, sorry if the writing is not good I use the google translator, I only speak Spanish.
commented Feb 26 by kenn (11,330 points)
Not sure if it is possible using gizmo in Unity. Gizmos are not normal objects.
To workaround, you can disable EasyAR's gizmo drawing and put an image object with same size in front of the target. The gizmo is used for object placement assistant in editor, so it will not affect runtime displays.
Welcome to EasyAR SDK Q&A, where you can ask questions and receive answers from other members of the community.
...