GLKViewController is deprecated

0 votes
asked Aug 17 by poornimasreedhar (200 points)

We are using EasyAR 3.1 which uses GLKit and GLKViewController. 

GLKit and GLKViewController are deprecated.

Apple recommends that we use MetalKit in place of GLKit. How to use EasyAR functionalities using MetalKit.

Is there any other option to support future IOS releases

1 Answer

+1 vote
answered Aug 18 by zhangpengar (3,020 points)
EasyAR Sense don't depend on OpenGLES or any other rendering API (except for VideoPlayer and Recording which depend on OpenGLES2/3).

Usage of GLKit and GLKViewController in HelloAR* samples is only to demonstrate the API workflow. You are free to use any other rendering API, such as Metal.

Metal is not cross-platform and makes it difficult for us to maintain the samples.

We have discussed a path via bgfx, which supports multiple rendering APIs, including Metal, but we are still at an early stage.
Welcome to EasyAR SDK Q&A, where you can ask questions and receive answers from other members of the community.
...