Easy AR - XCode bitcode problem.

0 votes
asked Jun 5, 2020 by elizeu159 (130 points)
edited Jun 5, 2020 by elizeu159
I can't build my unity project developed with easy ar to my phone. XCode keeps giving me this bitcode error.

/Frameworks/Plugins/iOS/easyar.framework/easyar(easyar-arm64-master.o)' does not contain bitcode. You must rebuild it with bitcode enabled (Xcode setting ENABLE_BITCODE), obtain an updated library from the vendor, or disable bitcode for this target.

I'm using

-Unity 2019.3.15

-EasyAR Sense 4.0.1

-Xcode 11.5

-iOS 13.5

EDIT: I'd like to add that recent xcode versions do not have the option to disable bitcode in the build settings, only when archiving is done and you are uploading to appstore you are given the option not to use it, but it gives me this error before the archive build is complete too

1 Answer

0 votes
answered Jul 6, 2020 by kenn (12,510 points)
Please see the document here: http://help.easyar.com/EasyAR%20Sense%20Unity%20Plugin/Guides/iOS-Project-Configuration.html#turn-off-bitcode

It is a screenshot from XCode 11.5, the bitcode option still exists.
commented Aug 14, 2020 by ruther (100 points)
Hi, I turned off the bit code but still get the same error
I'm use Easy AR v.4.1.0 and Unity 2020 + Xcode 11.6


/Users/admin/Desktop/ARVideo/Frameworks/Plugins/iOS/easyar.framework/easyar(easyar-arm64-master.o)' does not contain bitcode. You must rebuild it with bitcode enabled (Xcode setting ENABLE_BITCODE), obtain an updated library from the vendor, or disable bitcode for this target.
clang: error: linker command failed with exit code 1 (use -v to see invocation)

How to solve this problem ?
commented Aug 16, 2020 by kenn (12,510 points)
There are multiple targets in the Unity generated XCode project. If you take a careful look into the build report, you will find out which target is throwing this error. Turn off bitcode for the exact target.
commented Apr 21 by lmcapazita (170 points)
I am having the same problem. I am dissabling bit code for the framework, which is the part throwing the error. Once I do that it just generates other new multiple errors.
commented Apr 21 by kenn (12,510 points)
If you are new to EasyAR, there is a chance to switch to latest version (4.3 at present), which does all post XCode settings automatically.
commented Apr 22 by lmcapazita (170 points)
I have purchased license. Can I switch to latest version as you suggest? Besides there is an android app already working with this license. I am completely lost with this issue. I hired a developer in order to solve it but he couldn't also. Can you help us? Thanks.
commented Apr 22 by kenn (12,510 points)
if you have one license key for 4.x, it can be used for all 4.x version.
Alternatively, to avoid upgrade the SDK, try to disable bitcode and add ARKit framework (like the document says) for every XCode target you can find, Unity generate different project layouts in different versions.
Welcome to EasyAR SDK Q&A, where you can ask questions and receive answers from other members of the community.
...