how to make app subbort for 64 bit.

0 votes
asked Jan 21 by raviraj (390 points)
I am getting an error while uploading app to play store, Can see only armeabi-v7a inside the JNI libs folder, how can I make it support for 64 bit, need this urgently please help.

1 Answer

0 votes
answered Jan 22 by bigbaak (720 points)
Hello, You need this steps for enable support 64-bit.

1. File -> Build Settings -> Player Settings.

2. In the tab: "Other Settings".

Change "Script Backend" from 'Mono' to "IL2CPP"

On the "Target Architectures" toggle on "ARM64".

Done.
commented Jan 22 by raviraj (390 points)
Thanks for quick response,
Hi, I don't see any settings name "build settings" section in Android studio, I am not using unity here,please help.
commented Jan 22 by bigbaak (720 points)
Ok, I upload my jniLibs for EasyAR 3.0 library which support 64-bit architecture.
Link:
https://drive.google.com/open?id=1ioVrgLNE4d5biGCjMj-SxTh7lRiodBDo
commented Jan 22 by raviraj (390 points)
Thanks a ton, but one problem getting this below error

No implementation found for boolean cn.easyar.engine.EasyARNative.nativeInit(java.lang.ClassLoader, android.content.Context, java.lang.String) (tried Java_cn_easyar_engine_EasyARNative_nativeInit and Java_cn_easyar_engine_EasyARNative_nativeInit__Ljava_lang_ClassLoader_2Landroid_content_Context_2Ljava_lang_String_2)

currently, this is how it is
ndk {
            abiFilters 'armeabi-v7a', 'arm64-v8a'
        }
Welcome to EasyAR SDK Q&A, where you can ask questions and receive answers from other members of the community.
...