VIO camera component

0 votes
asked Jan 7 by ludsinz (190 points)

HI all.

i am giving a try to the 4.0.0 version of EasyAR (on Unity3D 2019.2.10f1). On Android 6.0.1 i get an error: "VIOCameraDevice not available". From the support page: What "Component VIOCameraDeviceUnion: motion tracker with auto switch when ARKit/ARCore or EasyAR Motion Tracker available on device"  means? Thank you all

1 Answer

0 votes
answered Jan 13 by easyarguxin (300 points)

ARCore and EasyAR MotionTracking only support  Android 7.0 or later.

VIO requirements for mobile phones:
1.iOS models need to support ARKit
2.Android models support ARCore or EasyAR motionTracking.

For the requirements of ARCore-supported models, please refer to the ARCore official website; 

For the requirements of EasyAR motionTracking, see https://help.easyar.cn/EasyAR%20Sense/v4/Guides/EasyAR-Motion-Tracking-Supported-Devices.html

commented Jan 14 by ludsinz (190 points)
@easyarguxin
. Thank you so much for your answer.
commented Jan 14 by bigbaak (480 points)
I have smartphone "Xiaomi Mi 5" on Android 8.0 . In the "MotionTracking " sample shows message "VIOCameraDevice not available".  Will this phone model be added to the list of supported devices?
commented Jan 14 by easyarguxin (300 points)
Everything is possible! More models may expand in the next version.
Welcome to EasyAR SDK Q&A, where you can ask questions and receive answers from other members of the community.
...