Linker command failed. Manual from your doc doesn't help

0 votes
asked Aug 20 by horunserhii (140 points)
edited Aug 20 by horunserhii
ld: '/Users/horuns/Desktop/Heart/Build/Frameworks/Plugins/iOS/easyar.framework/easyar(easyar-armv7-master.o)' does not contain bitcode. You must rebuild it with bitcode enabled (Xcode setting ENABLE_BITCODE), obtain an updated library from the vendor, or disable bitcode for this target. for architecture armv7

clang: error: linker command failed with exit code 1 (use -v to see invocation)

Hello. I get this error every time when I try to build it for iOS in xCode (from Unity engine). I disabled bitcode, and even try to use only ARM64 architecture, but still get this error.

please help asap. I have deadline in 4 days.

Edit:

Same issue for ARM64:

ld: '/Users/horuns/Desktop/Heart/Build/Frameworks/Plugins/iOS/easyar.framework/easyar(easyar-arm64-master.o)' does not contain bitcode. You must rebuild it with bitcode enabled (Xcode setting ENABLE_BITCODE), obtain an updated library from the vendor, or disable bitcode for this target. for architecture arm64

clang: error: linker command failed with exit code 1 (use -v to see invocation)

Disabling bitcode in xCode doesn't help

2 Answers

0 votes
answered Oct 4 by romanv (140 points)
I have the same issue. Did you resolve a problem?
0 votes
answered Oct 7 by rlmidiaalvs (1,380 points)

Hey Romanv and horunserhii, check:

*Project* -> Unity-Iphone -> Build Settings -> Build Options -> Enable Bitcode -> set to NO.

*Targets* -> Unity-Iphone -> Build Settings -> Build Options -> Enable Bitcode -> set to NO.

Welcome to EasyAR SDK Q&A, where you can ask questions and receive answers from other members of the community.
...