Video not showing with EasyAr 2.3 and recent Unity versions

0 votes
asked Aug 15, 2019 by lupamac (120 points)
I'm having many problems to use videos as augmented objects. I never managed it to work with recent Unity versions, so I kept using Unity 5.6.6 and EasyAR 2.3. It works fine, but I cannot post the app on the Google Play Store because Unity 5.6 doesn`t support API 28. So I tried all version of Unity 2017, 2018, and 2019.

Using default options (with the exception of Auto API, which I turn off to not get blackscreen) the plane with the video don`t appear, but the audio is played. If I unckeck multithreaded rendering the plane is showed, but the image of the video still doesn`t.

I really don`t konow what to to. I tried anything I could think. Any suggestions?

1 Answer

0 votes
answered Aug 16, 2019 by zhnagjian (10,740 points)
HelloARVideo of SDK 2.3.0 don't support unity 2018+, you can use unity videoplayer directly or why not use SDK 3.0.1(SDK 3.0.1 supports unity 2018 or 2019)
commented Aug 16, 2019 by lupamac (120 points)
Thank you very much for your reply. The release notes of version 2.3 imply that Unity 2018 is supported, but perhaps not all functions. I would like to try version 3.0.1, but they changed everything and I don't even know how to start. There is no EasyAR_Startup and I could not even find how to insert an image target.

Do you know if there is an tutorial or video explaining how to you the SDK 3.0.1? I just need to create a few image targets ad associate videos to some and 3D models to others.

Welcome to EasyAR SDK Q&A, where you can ask questions and receive answers from other members of the community.