Issue while recording (Android)

0 votes
asked Jul 16, 2019 by fokslab (200 points)

I tried the trial Unity package for Pro version but cannot achieve to record video (feature which is interesting me in the Pro version). Messages are well written on screen giving the directory where I could find the recorded MP4 but I cannot find anything in the given directory (I have checked on the phone & external SD card). Could you please help me about this feature ?


1 Answer

0 votes
answered Jul 18, 2019 by emanuel (390 points)
I've come into this issue and solved by changing the write permission in Player Settings, where "Install Location" is set to "Prefer External" and "Write Permission"  to "External (SDCard)". If the error persists try to change your Android Manifest.

And just to be shure, the file recorded is saved at: "Android/data/<Your android app package name>/files/"
commented Jul 18, 2019 by fokslab (200 points)
I already checked the Android/data/<myAppName>/files directory on both storages (internal & external) and even if easyAR tells the video is saved (through popup message) nothing can be found there.
The permission settings are already set in player settings and manifest seems OK when reading it (all the <uses-permission> are set). What do you advise me to change in the
Android Manifest ?
commented Jul 19, 2019 by emanuel (390 points)
Make shure this line is written in your Android Manifest: "<uses-permission android:name="android.permission.WRITE_EXTERNAL_STORAGE" />".

Also, I couldn't Record a video in the version 2, only in the newest version 3, using the sample scene provided.
commented Jul 19, 2019 by fokslab (200 points)
Android manifest includes this line (and I'm using the EasyAR Pro 3 recording sample too). I do not understand what's going wrong. I will try with another smartphone to be sure.
Welcome to EasyAR SDK Q&A, where you can ask questions and receive answers from other members of the community.