EasyAR 3.0 Unity Editor Webcam not working

+3 votes
asked Jul 9, 2019 by planxp (150 points)
Should it work on the editor with a webcam? Tried 2018.4 and 2019.1.

2 Answers

+2 votes
answered Jul 9, 2019 by juvelez (910 points)
Same Issue Here, and with the EasyARSense_3.0.0-final_ExternalCamera that I thought was for use external cameras on Windows Platforms, I received the Message: "Only Support Mobile Phone", so EasyAR 3.0 doesn't support Windows anymore?, what External Camera means?
commented Jul 9, 2019 by ngc6543 (1,670 points)
I remember the external camera is for mobile devices that doesn't have a built-in camera and thus requires external usb webcam.

Also, if you want to run the SDK in the editor or standalone, try to set Frame Source Type to 'Easyar' in ARSession component.
commented Jul 10, 2019 by zhnagjian (11,130 points)
Do you run the sample of  HelloAR_ImageTarge or HelloAR_ExternalCamera ?
What is the version of your windows system?
 What is the WebCamera model?
commented Jul 10, 2019 by juvelez (910 points)
I ran every sample in the Unity Package, without any of them the camera is detected, I compiled for Android too, and also is not working on Moto G6/G6 Plus/Moto One with Last Oreo, and on Asus HD7 Tablet with 4.4 Android.

The system is the same system I used to work with 2.3 SDK, Windows 10 x64, tested Unity version: 2017.4.29f1, 2018.4.3f1, and 2019.1.8f1. I use a Microsoft Webcam, LifeCAM HD-3000 720p camera, is the same testing camera I always use.

The 2.3 worked pretty fine, the only lack was Android x64, I thing before give that big Jump to the 3.0 SDK, with ALL working pipeline changed, prior projects cant be upgraded, must be started from ground, must implement a 2.4 or 2.5 version of the SDK with x64 Android support and fix some minor Bugs, and it would be perfect
0 votes
answered Sep 18, 2019 by matthewmr (140 points)
edited Sep 18, 2019 by matthewmr

I had the same issue. Try to disable the default camera from "Control Panel>HardwareAndSound>DevicesAndPrinters>DeviceManager>Cameras>RightClick>DisableDevice". Unity editor uses automatically the WebCam you have connected. This worked for me. Hope this helps! 

#Unity 2019.2.5f1

#EasyAR 3.0.1

#Windows 10

Welcome to EasyAR SDK Q&A, where you can ask questions and receive answers from other members of the community.