Invalid Key or Package name Error - solved?

+7 votes
asked Apr 14, 2018 by bradjensen68 (450 points)
I was having the same issue that many people here have reported.  That either immediately or after 4 minutes that I would get the message "Invalid Key or Package name Error".  I changed the name on my EasyAR account (was initally incorrect) and the package name to match.  (Just to be clear, the instructions talk about a Bundle ID but that is incorrect - it is the package name under Build Setting -> Package Settings -> Other Settings -> Package Name and is in the format com.YourCompany,YourApp and your also have to put it in the EasyAR account under the PackageName ID exactly in the same format)

However this initially did not work and cause me a lot of problems.  Eventually I thought that maybe changing the name has something to do with it, so I deleted the SDK license key and then recreate it and then copied the new key to Unity and then rebuilt.  

Now everything seems to be working fine.  My guess is that the SDK License uses the name of the project to generate the  key but then does not update if you change the name and therefore causes an error.  Anyway, it worked for me and I thought I would share to help out anyone that was as frustrated as I was.

2 Answers

0 votes
answered Apr 16, 2018 by easyar0807 (1,020 points)
That might be a good solution.
+1 vote
answered Aug 9, 2018 by bgg1206 (230 points)
I have the same problem

With the first try I used a licence it works perfectly fine.

But now with another licence, show the invalid key error, I´ve deleted the new license 10 times and the same error appears.
If I use the first licence number and name in the new application it works perfectly fine.

Seems there´s a problem when you have multiple licences or I don´t know what else could be.

Hope someone can help me with this problem
commented Aug 10, 2018 by bombardieri (100 points)
I´ve opened a  new Account.
I used two new licences for iOS and worked perfect,
but I try to use the same info for Android doesn´t work.

Seem there´s a problem with the licences
Welcome to EasyAR SDK Q&A, where you can ask questions and receive answers from other members of the community.